文書番号 : S1004191075095 / 最終更新日 : 2019/03/19

[Windows 7] 外字エディターを使用して外字を作成する方法

    Q

    [Windows 7]
    外字エディターを使用して外字を作成する方法


    「外字エディター」を使用して外字を作成、編集、および入力する方法を教えてください。


    A

    [コードの選択]画面から操作してください


    対象製品

    Windows 7

    内容

    事前確認

    ご注意

    外字は作成したPCでご使用ください。
    ほかのPCでの使用は、動作保証をしておりません。

    目次に戻る

    操作方法

    外字を作成する方法

    操作手順

    • 下記は例として、コード:F040に[指定したフォントにリンクする]設定で登録する方法を説明します。
    1. [スタート]ボタンをクリックし、[すべてのプログラム]-[アクセサリ]-[システム ツール]-[外字エディター]をクリックします。

      参考

      [システムツール]に[外字エディター]が表示されていない場合は、[スタート]ボタンをクリックし、[プログラムとファイルの検索]欄に「eudcedit.exe」と入力して[Enter]キーを押してください。

    2. [コードの選択]画面が表示されるので、F040の四角をクリックし、[OK]ボタンをクリックします。

      [コードの選択]画面

    3. [外字エディター]画面が表示されるので、外字を作成します。

      [外字エディター]画面

    4. [編集]メニューをクリックして、[同じコードで保存]をクリックします。

      [編集]メニュー画面

    5. [ファイル]メニューをクリックして、[フォントのリンク]をクリックします。

      [ファイル]メニュー画面

    6. [フォントのリンク]画面が表示されるので、[外字フォントの種類]欄の[指定したフォントにリンクする]にチェックをつけます。

      [フォントのリンク]画面

      参考

      「外字エディター」を使用して外字を作成する場合、作成した外字をフォントライブラリーに含まれるすべてのフォント、または指定したフォントに関連付けることができます。

      • すべてのフォントに関連付けた場合:
        共通の外字として登録され、どのフォントを選択しても登録した外字を表示できます。

      • 指定したフォントに関連付けた場合:
        特定のフォントでのみ外字を表示できます。

    7. [フォントのリンク]画面が表示されるので、[フォントの選択]欄で、外字ファイルを関連付けるフォントをクリックし、[名前を付けて保存]ボタンをクリックします。

      [フォントのリンク]画面

      参考

      一覧には、左側にフォント名、右側に関連付けられているファイル名が表示されます。
      ファイル名に[未選択]と表示されている場合には、外字ファイルが関連付けられていません。
      また、指定したフォントに関連付けて作成された外字は特定のフォントのみ使用できますが、特定のフォントに関連付けることによって、その書体に似たデザインに変更されるわけではありません。

    8. [外字ファイル名の変更]画面が表示されるので、[ファイル名]欄に任意の名前を入力し、[フォルダーの参照]をクリックし外字ファイルを保存する場所を指定して、[保存]ボタンをクリックします。

      [外字ファイル名の変更]画面

    9. [フォントのリンク]画面の[OK]ボタンをクリックします。

      [フォントのリンク]画面

      参考

      作成した外字は登録するフォントごとに「*.TTE」、および「*.EUF」として保存されます。

      • すべてのフォントに関連付けた場合:
        「EUDC.TTE」、および「EUDC.EUF」という名前のファイルで保存されます。

      • 指定したフォントに関連付けた場合:
        任意のファイル名で拡張子は「*.TTE」、および「*.EUF」として保存されます。

      拡張子が「*.TTE」のファイルは外字フォントのデータが格納され「*.EUF」のファイルは外字フォントの管理に使用されます。

    目次に戻る

    外字を編集する方法

    操作手順

    1. [スタート]ボタンをクリックし、[すべてのプログラム]-[アクセサリ]-[システム ツール]-[外字エディター]をクリックします。

    2. [コードの選択]画面が表示されるので、編集したい外字をクリックし、[OK]ボタンをクリックします。

    3. 外字を編集し、[編集]メニューの[同じコードで保存]をクリックし、編集した外字を保存します。

    目次に戻る

    外字を入力する方法

    操作手順

    1. 外字を入力したい任意のソフトウェアを起動します。

    2. 外字を入力したい場所で「がいじ」と入力し、[F5]キー、または[Ctrl]+[Y]キーを押します。

    3. [IMEパッド]画面が表示されるので、外字が登録されているフォントを選択して、入力したい外字を表示します。

    4. 入力したい外字をクリックします。

    目次に戻る

    参考情報

    マイクロソフト社サポート技術情報
    [文章番号]
    416747
    [最終更新日]
    2009/8/25
    [タイトル]
    Windows で外字エディタを使用して外字を作成する方法

    目次に戻る

    目次に戻る

    ■ Q&Aで解決できなかった時にお役立てください。